rails_admin ruby 跨站请求伪造漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1234196 漏洞类型 跨站请求伪造
发布时间 2017-10-29 更新时间 2018-07-06
CVE编号 CVE-2016-10522 CNNVD-ID CNNVD-201711-005
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201711-005
|漏洞详情
rails_admin ruby是一个支持使用界面管理数据的Rails引擎。 rails_admin ruby 1.1.1之前版本中存在跨站请求伪造漏洞,该漏洞源于Non-GET方法没有验证跨站请求伪造令牌。攻击者可利用该漏洞获取被gem所公开的应用程序管理端点的访问权限。
|参考资料

来源:github.com

链接:https://github.com/sferik/rails_admin/commit/b13e879eb93b661204e9fb5e55f7afa4f397537a


来源:www.sourceclear.com

链接:https://www.sourceclear.com/blog/Rails_admin-Vulnerability-Disclosure/


来源:www.sourceclear.com

链接:https://www.sourceclear.com/registry/security/cross-site-request-forgery-csrf-/ruby/sid-3173