PHP 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1239431 漏洞类型 缓冲区错误
发布时间 2018-08-03 更新时间 2019-08-20
CVE编号 CVE-2018-14851 CNNVD-ID CNNVD-201808-064
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201808-064
|漏洞详情
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。 PHP中的ext/exif/exif.c文件的exif_process_IFD_in_MAKERNOTE存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。以下版本受到影响:PHP 5.6.37之前版本,7.0.31之前的7.0.x版本,7.1.20之前的7.1.x版本,7.2.8之前的7.2.x版本。
|参考资料

来源:php.net

链接:http://php.net/ChangeLog-5.php


来源:php.net

链接:http://php.net/ChangeLog-7.php


来源:bugs.php.net

链接:https://bugs.php.net/bug.php?id=76557