ImageMagick 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1292876 漏洞类型 缓冲区错误
发布时间 2018-09-04 更新时间 2019-10-23
CVE编号 CVE-2018-16412 CNNVD-ID CNNVD-201809-092
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201809-092
|漏洞详情
ImageMagick是美国ImageMagick Studio公司的一套开源的图象处理软件。该软件可读取、转换、写入多种格式的图片。 ImageMagick 7.0.8-11 Q16版本中的coders/psd.c文件的‘ParseImageResourceBlocks’函数存在基于堆的缓冲区溢出漏洞。攻击者可利用该漏洞执行任意代码或造成拒绝服务(基于堆的缓冲区越界读取)。
|参考资料

来源:github.com

链接:https://github.com/ImageMagick/ImageMagick/issues/1250