Artifex Ghostscript 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1298517 漏洞类型 缓冲区错误
发布时间 2018-09-07 更新时间 2019-10-24
CVE编号 CVE-2018-16585 CNNVD-ID CNNVD-201809-326
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201809-326
|漏洞详情
Artifex Software Ghostscript是美国Artifex Software公司的一款开源的PostScript(一种用于电子产业和桌面出版领域的页面描述语言和编程语言)解析器。该产品可显示Postscript文件以及在非Postscript打印机上打印Postscript文件。 Artifex Ghostscript 9.24之前版本中存在缓冲区错误漏洞,该漏洞源于在处理文档时,程序接收了本不应该使用的.setdistillerkeys PostScript命令。远程攻击者可通过提交特制的PostScript利用该漏洞造成解析器崩溃。
|参考资料

来源:git.ghostscript.com

链接:http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=1497d65039885a52b598b137dd8622bd4672f9be


来源:git.ghostscript.com

链接:http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=971472c83a345a16dac9f90f91258bb22dd77f22


来源:seclists.org

链接:https://seclists.org/oss-sec/2018/q3/182