mgetty 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1309701 漏洞类型 操作系统命令注入
发布时间 2018-09-14 更新时间 2019-10-23
CVE编号 CVE-2018-16741 CNNVD-ID CNNVD-201809-680
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201809-680
|漏洞详情
mgetty是一款getty的替代程序,用于数据和传真操作。 mgetty 1.2.1之前版本中存在安全漏洞,该漏洞源于在fax/faxq-helper.c文件中,‘do_activate()’函数没有正确的过滤shell元字符。攻击者可借助shell元字符利用该漏洞注入命令,并以faxrunq/faxq用户权限执行该命令。
|参考资料

来源:lists.debian.org

链接:https://lists.debian.org/debian-lts-announce/2018/09/msg00012.html


来源:www.debian.org

链接:https://www.debian.org/security/2018/dsa-4291


来源:www.x41-dsec.de

链接:https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty