Haxx curl 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1377089 漏洞类型 缓冲区错误
发布时间 2018-11-01 更新时间 2019-12-04
CVE编号 CVE-2018-16839 CNNVD-ID CNNVD-201810-1551
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201810-1551
|漏洞详情
Haxx curl是瑞典Haxx公司的一套利用URL语法在命令行下工作的文件传输工具。该工具支持文件上传和下载,并包含一个用于程序开发的libcurl(客户端URL传输库)。 Haxx curl 7.33.0版本至7.61.1版主中的SASL身份验证代码存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16839


来源:curl.haxx.se

链接:https://curl.haxx.se/docs/CVE-2018-16839.html


来源:github.com

链接:https://github.com/curl/curl/commit/f3a24d7916b9173c69a3e0ee790102993833d6c5