WordPress Ninja Forms插件安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1419331 漏洞类型 输入验证错误
发布时间 2018-12-04 更新时间 2020-03-04
CVE编号 CVE-2018-19796 CNNVD-ID CNNVD-201812-031
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201812-031
|漏洞详情
WordPress是WordPress软件基金会的一套使用PHP语言开发的博客平台,该平台支持在PHP和MySQL的服务器上架设个人博客网站。Ninja Forms plugin是使用在其中的一个表单创建组件。 WordPress Ninja Forms插件3.3.19.1之前版本中存在开放重定向漏洞。远程攻击者可通过向lib/StepProcessing/step-processing.php页面发送‘redirect’参数利用该漏洞将用户重定向到其他网站。
|参考资料

来源:plugins.trac.wordpress.org

链接:https://plugins.trac.wordpress.org/changeset/1982808/ninja-forms/trunk/lib/StepProcessing/step-processing.php


来源:wordpress.org

链接:https://wordpress.org/plugins/ninja-forms/#developers