CloudBees Jenkins Pipeline: Groovy Plugin 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1430726 漏洞类型 权限许可和访问控制问题
发布时间 2018-12-11 更新时间 2019-10-08
CVE编号 CVE-2018-1000866 CNNVD-ID CNNVD-201812-391
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201812-391
|漏洞详情
CloudBees Jenkins(前称Hudson Labs)是美国CloudBees公司的一套基于Java开发的持续集成工具,该工具主要用于监控秩序重复的工作。Pipeline:Groovy Plugin是其中的一个基于Java开发的持续集成工具中的流程构建插件。 CloudBees Jenkins中的Pipeline: Groovy Plugin 2.59及之前版本的groovy-sandbox/src/main/java/org/kohsuke/groovy/sandbox/SandboxTransformer.java文件和groovy-cps/lib/src/main/java/com/cloudbees/groovy/cps/SandboxCpsTransformer.java文件存在安全漏洞。攻击者可利用该漏洞在Jenkins master JVM上执行任意代码。
|参考资料

来源:jenkins.io

链接:https://jenkins.io/security/advisory/2018-10-29/#SECURITY-1186