Facebook HHVM和folly library 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1450178 漏洞类型 缓冲区错误
发布时间 2019-01-02 更新时间 2019-10-17
CVE编号 CVE-2018-6337 CNNVD-ID CNNVD-201812-1314
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201812-1314
|漏洞详情
Facebook HHVM和folly library都是美国Facebook公司的产品。Facebook HHVM(又名HipHop Virtual Machine)是一款能够显著提高PHP加载动态页面性能的虚拟机。folly library是一个开源C++库。 Facebook HHVM 3.26.3之前的3.26版本和folly library 2017.12.11.00版本至2018.08.09.00版本中存在安全漏洞。攻击者可利用该漏洞造成多个分叉的子进程生成多个重复或类似的结果。
|参考资料

来源:github.com

链接:https://github.com/facebook/folly/commit/8e927ee48b114c8a2f90d0cbd5ac753795a6761f


来源:github.com

链接:https://github.com/facebook/hhvm/commit/e2d10a1e32d01f71aaadd81169bcb9ae86c5d6b8


来源:hhvm.com

链接:https://hhvm.com/blog/2018/05/24/hhvm-3.26.3.html