systemd 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1450335 漏洞类型 缓冲区错误
发布时间 2019-01-09 更新时间 2019-04-17
CVE编号 CVE-2018-16864 CNNVD-ID CNNVD-201901-358
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://www.securityfocus.com/bid/106523
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201901-358
|漏洞详情
systemd是德国Lennart Poettering软件开发者的一款基于Linux的系统和服务管理器。该产品兼容了SysV和LSB的启动脚本,且提供了一个用来表示系统服务间依赖关系的框架。systemd-journald是其中的一个用于收集和存储日志数据的系统服务。 systemd中的systemd-journald存在基于栈的缓冲区溢出漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/systemd-memory-corruption-via-alloca-28232