Docker runc 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1480820 漏洞类型
发布时间 2019-02-11 更新时间 2019-02-12
CVE编号 CVE-2019-5736 CNNVD-ID CNNVD-201902-316
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201902-316
|漏洞详情
Docker是美国Docker公司的一款开源的应用容器引擎。该产品支持在Linux系统上创建一个容器(轻量级虚拟机)并部署和运行应用程序,以及通过配置文件实现应用程序的自动化安装、部署和升级。 Docker 18.09.2之前版本和其他产品中的runc 1.0-rc6及之前版本中存在安全漏洞,该漏洞源于程序没有正确地处理文件描述符。攻击者可利用该漏洞覆盖主机runc的二进制文件并以root权限执行命令。
|参考资料

来源:www.openwall.com

链接:https://www.openwall.com/lists/oss-security/2019/02/11/2


来源:github.com

链接:https://github.com/opencontainers/runc/commit/6635b4f0c6af3810594d2770f662f34ddc15b40d


来源:github.com

链接:https://github.com/opencontainers/runc/commit/0a8e4117e7f715d5fbeef398405813ce8e88558b


来源:github.com

链接:https://github.com/docker/docker-ce/releases/tag/v18.09.2


来源:access.redhat.com

链接:https://access.redhat.com/security/vulnerabilities/runcescape


来源:access.redhat.com

链接:https://access.redhat.com/security/cve/cve-2019-5736


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-5736