Bitcoin Core和Bitcoin Knots 访问控制错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1480823 漏洞类型 访问控制错误
发布时间 2019-02-11 更新时间 2019-02-12
CVE编号 CVE-2018-20587 CNNVD-ID CNNVD-201902-313
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201902-313
|漏洞详情
Bitcoin Core是一款用于验证区块链交易有效性的开源客户端。Bitcoin Knots是一个完整的比特币客户端。 Bitcoin Core 0.12.0版本至0.17.1版本和Bitcoin Knots 0.12.0版本至0.17.1.knots20181229之前版本中存在访问控制错误漏洞。本地攻击者可通过绑定RPC IPv4本地主机端口并向IPv6本地主机端口转发请求利用该漏洞窃取用户的虚拟货币。
|参考资料

来源:medium.com

链接:https://medium.com/@lukedashjr/cve-2018-20587-advisory-and-full-disclosure-a3105551e78b


来源:en.bitcoin.it

链接:https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures#CVE-2018-20587


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2018-20587