Binaryen 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1480827 漏洞类型 缓冲区错误
发布时间 2019-02-10 更新时间 2019-02-12
CVE编号 CVE-2019-7701 CNNVD-ID CNNVD-201902-299
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201902-299
|漏洞详情
Binaryen 1.38.22版本中的wasm-s-parser.cpp文件的‘wasm::SExpressionParser::skipWhitespace()’函数存在基于堆的缓冲区越界读取漏洞。攻击者可借助特制的输入利用该漏洞造成拒绝服务(段错误)。
|参考资料

来源:github.com

链接:https://github.com/WebAssembly/binaryen/issues/1863ExploitPatchThird Party Advisory


来源:github.com

链接:https://github.com/WebAssembly/binaryen/issues/1863


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-7701