OpenSSL 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1522426 漏洞类型 加密问题
发布时间 2019-03-06 更新时间 2019-07-17
CVE编号 CVE-2019-1543 CNNVD-ID CNNVD-201903-162
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://www.securityfocus.com/bid/107349
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201903-162
|漏洞详情
OpenSSL是OpenSSL团队的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库。该产品支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。 OpenSSL 1.1.1版本和1.1.0版本中存在加密问题漏洞。该漏洞源于网络系统或产品未正确使用相关密码算法,导致内容未正确加密、弱加密、明文存储敏感信息等。
|受影响的产品
Oracle VM VirtualBox 6.0.10 Oracle VM VirtualBox 5.2.32 OpenSSL Project OpenSSL 1.1.1c-dev OpenSSL Project OpenSSL 1.1.0k-dev
|参考资料

来源:www.openssl.org

链接:https://www.openssl.org/news/secadv/20190306.txt


来源:git.openssl.org

链接:https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=f426625b6ae9a7831010750490a5f0ad689c5ba3


来源:git.openssl.org

链接:https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=ee22257b1418438ebaf54df98af4e24f494d1809


来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/OpenSSL-information-disclosure-via-ChaCha20-Poly1305-Long-Nonces-28682


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-1543