CloudBees Jenkins Script Security Plugin 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1529042 漏洞类型 安全特征问题
发布时间 2019-03-08 更新时间 2019-04-12
CVE编号 CVE-2019-1003029 CNNVD-ID CNNVD-201903-296
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201903-296
|漏洞详情
CloudBees Jenkins(Hudson Labs)是美国CloudBees公司的一套基于Java开发的持续集成工具。该产品主要用于监控持续的软件版本发布/测试项目和一些定时执行的任务。Script Security Plugin是使用在其中的一个脚本安全插件。 CloudBees Jenkins Script Security Plugin 1.53及之前版本中的多个文件存在安全特征问题漏洞。攻击者可利用该漏洞在Jenkins master上执行任意代码。(文件包括:src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java和src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java)
|参考资料

来源:jenkins.io

链接:https://jenkins.io/security/advisory/2019-03-06/#SECURITY-1336%20(1)


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-1003029