IBM DB2 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1559390 漏洞类型 缓冲区错误
发布时间 2019-04-02 更新时间 2019-07-02
CVE编号 CVE-2018-1936 CNNVD-ID CNNVD-201904-046
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201904-046
|漏洞详情
IBM DB2是美国IBM公司的一套关系型数据库管理系统。该系统的执行环境主要有UNIX、Linux、IBMi、z/OS以及Windows服务器版本。 IBM DB2 libdb2e.so.1中存在基于栈的缓冲区溢出漏洞,该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。以下产品及版本受到影响:IBM DB2 9.7版本,10.1版本,10.5版本,11.1版本。
|参考资料

来源:www-01.ibm.com

链接:https://www-01.ibm.com/support/docview.wss?uid=ibm10741481


来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/IBM-DB2-buffer-overflow-via-libdb2e-so-1-28910