Poppler 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1562467 漏洞类型 缓冲区错误
发布时间 2019-04-08 更新时间 2019-04-09
CVE编号 CVE-2019-11026 CNNVD-ID CNNVD-201904-321
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201904-321
|漏洞详情
Poppler是一个用于生成PDF的C++类库,该库是从Xpdf(PDF阅读器)继承而来。 Poppler 0.75.0版本中的Error.cc文件的‘error ()’函数存在缓冲区溢出漏洞,该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:MISC

链接:https://research.loginsoft.com/bugs/1508/


来源:MISC

链接:https://gitlab.freedesktop.org/poppler/poppler/issues/752