libsixel 输入验证错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1562473 漏洞类型 输入验证错误
发布时间 2019-04-08 更新时间 2019-04-09
CVE编号 CVE-2019-11024 CNNVD-ID CNNVD-201904-315
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201904-315
|漏洞详情
libsixel是一个为DEC SIXEL图形和其他转换器程序提供编码/解码实现的软件包。 libsixel 1.8.2版本中的libsixel.a静态链接库的frompnm.c文件的‘load_pnm’函数存在输入验证错误漏洞,该漏洞源于网络系统或产品未对输入的数据进行正确的验证。
|参考资料

来源:MISC

链接:https://research.loginsoft.com/bugs/1501/


来源:MISC

链接:https://github.com/saitoha/libsixel/issues/85