PHP imagick extension 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1596522 漏洞类型 缓冲区错误
发布时间 2019-05-10 更新时间 2019-05-10
CVE编号 CVE-2019-11037 CNNVD-ID CNNVD-201905-105
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://www.securityfocus.com/bid/108292
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-105
|漏洞详情
PHP imagick extension 3.3.0版本至3.4.4版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|受影响的产品
PHP Imagick 3.4.4RC1
|参考资料

来源:bugs.php.net

链接:https://bugs.php.net/bug.php?id=77791


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-11037