cJSON 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1602775 漏洞类型 缓冲区错误
发布时间 2019-05-09 更新时间 2019-05-10
CVE编号 CVE-2019-11834 CNNVD-ID CNNVD-201905-218
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-218
|漏洞详情
cJSON是一款轻量级的开源JSON解析器。 cJSON 1.7.11之前版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/DaveGamble/cJSON/releases/tag/v1.7.11


来源:github.com

链接:https://github.com/DaveGamble/cJSON/issues/337


来源:github.com

链接:https://github.com/DaveGamble/cJSON/compare/c69134d...93688cb


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-11834