GNU Recutils 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1603997 漏洞类型 缓冲区错误
发布时间 2019-05-01 更新时间 2019-05-08
CVE编号 CVE-2019-11640 CNNVD-ID CNNVD-201905-045
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-045
|漏洞详情
GNU Recutils是GNU计划的一款用于访问recfiles纯文本数据库的工具和库。 GNU recutils 1.8版本中的librec.a静态链接库的rec-fex.c文件的‘rec_fex_parse_str_simple’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/TeamSeri0us/pocs/tree/master/recutils/bug-report-recutils/recfix


来源:github.com

链接:https://github.com/TeamSeri0us/pocs/blob/master/recutils/bug-report-recutils/


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-11640