Rockwell Automation CompactLogix 5370 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1604054 漏洞类型 缓冲区错误
发布时间 2019-04-30 更新时间 2019-05-08
CVE编号 CVE-2019-10954 CNNVD-ID CNNVD-201904-1337
漏洞平台 N/A CVSS评分 7.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201904-1337
|漏洞详情
Rockwell Automation CompactLogix 5370是美国罗克韦尔(Rockwell Automation)公司的一款可编程逻辑控制器。 Rockwell Automation CompactLogix 5370中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。以下版本受到影响:Rockwell Automation CompactLogix 5370 L1 controllers 20版本至30.014及之前版本,CompactLogix 5370 L2 controllers 20版本至30.014及之前版本,CompactLogix 5370 L3 controllers 20版本至30.014及之前版本,Compact GuardLogix 5370 controllers 20版本至30.014及之前版本,Armor Compact GuardLogix 5370 controllers 20版本至30.014及之前版本。
|参考资料

来源:www.securityfocus.com

链接:http://www.securityfocus.com/bid/108118


来源:www.rockwellautomation.com

链接:http://www.rockwellautomation.com/


来源:www.securityfocus.com

链接:https://www.securityfocus.com/bid/108118


来源:www.nsfocus.net

链接:http://www.nsfocus.net/vulndb/43208


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10954


来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/79922


来源:ics-cert.us-cert.gov

链接:https://ics-cert.us-cert.gov/advisories/ICSA-19-120-01