GitLab 注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1616046 漏洞类型 注入
发布时间 2019-05-17 更新时间 2019-05-20
CVE编号 CVE-2018-19585 CNNVD-ID CNNVD-201905-736
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-736
|漏洞详情
GitLab是美国GitLab公司的一款使用Ruby on Rails开发的、自托管的、Git(版本控制系统)项目仓库应用程序。该程序可用于查阅项目的文件内容、提交历史、Bug列表等。 GitLab(社区版和企业版)中存在注入漏洞。该漏洞源于用户输入构造命令、数据结构或记录的操作过程中,网络系统或产品缺乏对用户输入数据的正确验证,未过滤或未正确过滤掉其中的特殊元素,导致系统或产品产生解析或解释方式错误。以下产品及版本受到影响:GitLab 8.18版本至11.x版本(11.3.11版本已修复),11.4.8之前的11.4.x版本,11.5.1之前的11.5.x版本。
|参考资料

来源:about.gitlab.com

链接:https://about.gitlab.com/blog/categories/releases/


来源:about.gitlab.com

链接:https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2018-19585