OpenEMR SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1616047 漏洞类型 SQL注入
发布时间 2019-05-17 更新时间 2019-05-20
CVE编号 CVE-2018-17181 CNNVD-ID CNNVD-201905-735
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-735
|漏洞详情
OpenEMR是OpenEMR社区的一套开源的医疗管理系统。该系统可用于医疗实践管理、电子医疗记录、处方书写和医疗帐单申请。 OpenEMR 5.0.1 Patch 7之前版本中的/portal/lib/appsql.class.php文件的‘portalAudit’函数和/portal/lib/paylib.php文件的‘SaveAudit’函数存在SQL注入漏洞。该漏洞源于基于数据库的应用缺少对外部输入SQL语句的验证。攻击者可利用该漏洞执行非法SQL命令。
|参考资料

来源:www.open-emr.org

链接:https://www.open-emr.org/wiki/index.php/OpenEMR_Patches#5.0.1_Patch_.289.2F9.2F18.29


来源:github.com

链接:https://github.com/openemr/openemr/commit/4963fe4932a0a4e1e982642226174e9931d09541


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2018-17181