NGINX njs 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1617353 漏洞类型 缓冲区错误
发布时间 2019-05-20 更新时间 2019-05-21
CVE编号 CVE-2019-12206 CNNVD-ID CNNVD-201905-804
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-804
|漏洞详情
NGINX是美国NGINX公司的一款轻量级Web服务器/反向代理服务器及电子邮件(IMAP/POP3)代理服务器。njs是其中的一个支持扩展NGINX功能的脚本语言组件。 NGINX中使用的njs 0.3.1及之前版本的nxt_utf8.c文件的‘nxt_utf8_encode’函数存在基于堆的缓冲区溢出漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/nginx/njs/issues/162


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12206