PHP 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1622797 漏洞类型 缓冲区错误
发布时间 2019-05-07 更新时间 2019-05-07
CVE编号 CVE-2019-11040 CNNVD-ID CNNVD-201906-057
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://www.securityfocus.com/bid/108520
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201906-057
|漏洞详情
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。EXIF extension是其中的一个用于读取和编写图像元数据的扩展。 PHP中的EXIF扩展存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。以下产品及版本受到影响:PHP 7.1.30之前的7.1.x版本,7.2.19之前的7.2.x版本,7.3.6之前的7.3.x版本。
|受影响的产品
PHP PHP 7.3.6 PHP PHP 7.2.19 PHP PHP 7.1.30
|参考资料

来源:lists.debian.org

链接:https://lists.debian.org/debian-lts-announce/2019/05/msg00047.html


来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.1986/