Xpdf 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1628467 漏洞类型 缓冲区错误
发布时间 2019-05-30 更新时间 2019-10-08
CVE编号 CVE-2019-12493 CNNVD-ID CNNVD-201905-1200
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201905-1200
|漏洞详情
Xpdf是Foo实验室的一款开源的PDF阅读器。该产品支持解码LZW压缩格式的文件以及阅读加密的PDF文件。 Xpdf 4.01.01版本中的Function.cc文件的‘PostScriptFunction::transform’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:forum.xpdfreader.com

链接:https://forum.xpdfreader.com/viewtopic.php?f=3&t=41806


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12493