WordPress 2by2host Widget Logic插件跨站请求伪造漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1651254 漏洞类型 跨站请求伪造
发布时间 2019-07-01 更新时间 2020-03-25
CVE编号 CVE-2019-12826 CNNVD-ID CNNVD-201907-007
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-007
|漏洞详情
WordPress是WordPress基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。2by2host Widget Logic plugin是使用在其中的一个网页小部件控制插件。 WordPress 2by2host Widget Logic插件5.10.2之前版本中的widget_logic.php文件存在跨站请求伪造漏洞。该漏洞源于WEB应用未充分验证请求是否来自可信用户。攻击者可利用该漏洞通过受影响客户端向服务器发送非预期的请求。
|参考资料

来源:plugins.trac.wordpress.org

链接:https://plugins.trac.wordpress.org/changeset/2112753/widget-logic


来源:dannewitz.ninja

链接:https://dannewitz.ninja/posts/widget-logic-csrf-to-rce


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12826