ImageMagick Studio ImageMagick 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1659376 漏洞类型 缓冲区错误
发布时间 2019-07-04 更新时间 2020-08-20
CVE编号 CVE-2019-13297 CNNVD-ID CNNVD-201907-298
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-298
|漏洞详情
ImageMagick Studio ImageMagick是美国ImageMagick Studio公司的一套开源的图像处理软件。该软件可读取、转换或写入多种格式的图片。 ImageMagick Studio ImageMagick 7.0.8-50 Q16版本中的MagickCore/threshold.c文件的‘AdaptiveThresholdImage’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/ImageMagick/ImageMagick6/commit/35c7032723d85eee7318ff6c82f031fa2666b773


来源:github.com

链接:https://github.com/ImageMagick/ImageMagick/issues/1609


来源:github.com

链接:https://github.com/ImageMagick/ImageMagick/commit/604588fc35c7585abb7a9e71f69bb82e4389fefc


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-13297