INSIDE Secure MatrixSSL 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1661825 漏洞类型 缓冲区错误
发布时间 2019-07-09 更新时间 2019-07-17
CVE编号 CVE-2019-13470 CNNVD-ID CNNVD-201907-523
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-523
|漏洞详情
INSIDE Secure MatrixSSL是法国INSIDE Secure公司的一个针对小型应用程序和设备而设计的嵌入式、开源SSLv3协议栈。 INSIDE Secure MatrixSSL 4.2.1之前版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/matrixssl/matrixssl/blob/4-2-1-open/doc/CHANGES_v4.x.md#changes-between-420-and-421-june-2019


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-13470