Cesanta Mongoose 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1663887 漏洞类型 缓冲区错误
发布时间 2019-07-10 更新时间 2019-07-12
CVE编号 CVE-2019-13503 CNNVD-ID CNNVD-201907-614
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-614
|漏洞详情
Cesanta Mongoose是爱尔兰Cesanta公司的一套嵌入式服务器库,它包括TCP、HTTP客户端和服务器、WenSocket客户端和服务器等功能。 Cesanta Mongoose 6.15版本中的mongoose.c文件的‘mq_parse_http’ 函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/cesanta/mongoose/pull/1035


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-13503