WordPress wp-code-highlightjs插件跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1674603 漏洞类型 跨站请求伪造
发布时间 2019-07-17 更新时间 2019-07-17
CVE编号 CVE-2019-12934 CNNVD-ID CNNVD-201907-1145
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://www.securityfocus.com/bid/109331
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-1145
|漏洞详情
WordPress是WordPress基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。wp-code-highlightjs plugin是使用在其中的一个高亮显示插件。 WordPress wp-code-highlightjs插件0.6.2及之前版本中存在跨站请求伪造漏洞。该漏洞源于WEB应用未充分验证请求是否来自可信用户。攻击者可利用该漏洞通过受影响客户端向服务器发送非预期的请求。
|受影响的产品
WordPress wp-code-highlightjs 0.6.3
|参考资料

来源:zeroauth.ltd

链接:https://zeroauth.ltd/blog/2019/07/17/cve-2019-12934-wp-code-highlightjs-wordpress-plugin-csrf-leads-to-blog-wide-injected-script-html/


来源:wordpress.org

链接:https://wordpress.org/plugins/wp-code-highlightjs/#developers


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12934