Jsish 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1676660 漏洞类型 缓冲区错误
发布时间 2019-07-23 更新时间 2019-07-24
CVE编号 CVE-2019-1010169 CNNVD-ID CNNVD-201907-1266
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-1266
|漏洞详情
Jsish是一款使用C语言编写的、内置数据库的小型JavaScript解析器。 Jsish 2.4.77_2.0477版本中的‘lexer_getchar’函数(jsiLexer.c文件)存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:MISC

链接:https://jsish.org/fossil/jsi/tktview/3a069014976f3422d9d96821dc555c8326c02ae3