JerryScript 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1678845 漏洞类型 缓冲区错误
发布时间 2019-07-25 更新时间 2019-08-06
CVE编号 CVE-2019-1010176 CNNVD-ID CNNVD-201907-1315
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-1315
|漏洞详情
JerryScript是一款轻量级的JavaScript引擎。 JerryScript commit 4e58ccf68070671e1fff5cd6673f0c1d5b80b166版本中的‘lit_char_to_utf8_bytes’函数(jerry-core/lit/lit-char-helpers.c文件)存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/jerryscript-project/jerryscript/issues/2476


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-1010176