CloudBees Jenkins Configuration as Code Plugin 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1685320 漏洞类型 输入验证错误
发布时间 2019-07-31 更新时间 2019-08-02
CVE编号 CVE-2019-10362 CNNVD-ID CNNVD-201907-1620
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201907-1620
|漏洞详情
CloudBees Jenkins(Hudson Labs)是美国CloudBees公司的一套基于Java开发的持续集成工具。该产品主要用于监控持续的软件版本发布/测试项目和一些定时执行的任务。Configuration as Code Plugin是使用在其中的一个Jenkins配置插件。 CloudBees Jenkins中的Configuration as Code Plugin 1.24及之前版本存在安全漏洞,该漏洞源于程序没有转义值。攻击者可利用该漏洞获取环境变量的值。
|参考资料

来源:jenkins.io

链接:https://jenkins.io/security/advisory/2019-07-31/#SECURITY-1446


来源:www.openwall.com

链接:http://www.openwall.com/lists/oss-security/2019/07/31/1


来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Jenkins-Plugins-multiple-vulnerabilities-29919


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10362