GNU cflow 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1735993 漏洞类型 缓冲区错误
发布时间 2019-09-09 更新时间 2019-09-10
CVE编号 CVE-2019-16166 CNNVD-ID CNNVD-201909-325
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201909-325
|漏洞详情
GNU cflow是GNU计划的一款流程图生成器,它能够读取C语言源文件并生成外部引用的流程图。 GNU cflow 1.6及之前版本中的parser.c文件的‘nexttoken’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:lists.gnu.org

链接:https://lists.gnu.org/archive/html/bug-cflow/2019-04/msg00000.html


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-16166