WordPress api-bearer-auth插件跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1742087 漏洞类型 跨站脚本
发布时间 2019-09-15 更新时间 2019-10-17
CVE编号 CVE-2019-16332 CNNVD-ID CNNVD-201909-713
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201909-713
|漏洞详情
WordPress是WordPress基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。api-bearer-auth是使用在其中的一个REST API的身份验证插件。 WordPress api-bearer-auth插件20190907之前版本中存在跨站脚本漏洞,该漏洞源于程序没有过滤‘server’参数。远程攻击者可利用该漏洞注入Javascript代码。
|参考资料

来源:wordpress.org

链接:https://wordpress.org/plugins/api-bearer-auth/#developers


来源:plugins.trac.wordpress.org

链接:https://plugins.trac.wordpress.org/changeset/2152730


来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/154369/WordPress-API-Bearer-Auth-20181229-Cross-Site-Scripting.html


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-16332