CloudBees Jenkins Script Security Plugin 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1772419 漏洞类型 代码注入
发布时间 2019-10-01 更新时间 2020-07-23
CVE编号 CVE-2019-10431 CNNVD-ID CNNVD-201910-004
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201910-004
|漏洞详情
CloudBees Jenkins(Hudson Labs)是美国CloudBees公司的一套基于Java开发的持续集成工具。该产品主要用于监控持续的软件版本发布/测试项目和一些定时执行的任务。Script Security Plugin是使用在其中的一个脚本安全插件。 CloudBees Jenkins Script Security Plugin 1.64及之前版本中存在代码注入漏洞。攻击者可利用该漏洞绕过沙盒保护,执行任意代码。
|参考资料

来源:jenkins.io

链接:https://jenkins.io/security/advisory/2019-10-01/#SECURITY-1579


来源:www.openwall.com

链接:http://www.openwall.com/lists/oss-security/2019/10/01/2


来源:jenkins.io

链接:https://jenkins.io/security/advisory/2019-10-01/


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10431


来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Jenkins-Plugins-multiple-vulnerabilities-30489


来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.3694/