GNU Aspell 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1782419 漏洞类型 缓冲区错误
发布时间 2019-10-13 更新时间 2019-11-25
CVE编号 CVE-2019-17544 CNNVD-ID CNNVD-201910-790
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201910-790
|漏洞详情
GNU Aspell是一款拼写检查工具。 GNU Aspell 0.60.8之前版本中的libaspell.a文件的acommon::unescape存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/GNUAspell/aspell/compare/rel-0.60.7...rel-0.60.8


来源:github.com

链接:https://github.com/GNUAspell/aspell/commit/80fa26c74279fced8d778351cff19d1d8f44fe4e


来源:bugs.chromium.org

链接:https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=16109


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-17544