ImageMagick Studio ImageMagick 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1782420 漏洞类型 缓冲区错误
发布时间 2019-10-13 更新时间 2019-10-25
CVE编号 CVE-2019-17540 CNNVD-ID CNNVD-201910-789
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201910-789
|漏洞详情
ImageMagick Studio ImageMagick是美国ImageMagick Studio公司的一套开源的图像处理软件。该软件可读取、转换或写入多种格式的图片。 ImageMagick Studio ImageMagick 7.0.8-54之前版本中的coders/ps.c文件的ReadPSInfo存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:github.com

链接:https://github.com/ImageMagick/ImageMagick/compare/master@%7B2019-07-15%7D...master@%7B2019-07-16%7D


来源:github.com

链接:https://github.com/ImageMagick/ImageMagick/compare/7.0.8-53...7.0.8-54


来源:bugs.chromium.org

链接:https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15826


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-17540