haml 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1783932 漏洞类型 跨站脚本
发布时间 2019-10-15 更新时间 2020-07-28
CVE编号 CVE-2017-1002201 CNNVD-ID CNNVD-201910-922
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201910-922
|漏洞详情
haml是Haml团队的一款开源的HTML抽象标记语言。 haml 5.0.0.beta.2之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。
|参考资料

来源:snyk.io

链接:https://snyk.io/vuln/SNYK-RUBY-HAML-20362


来源:github.com

链接:https://github.com/haml/haml/commit/18576ae6e9bdcb4303fdbe6b3199869d289d67c2


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2017-1002201