Zend Framework PostgreSQL ZendDb adapter SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1800788 漏洞类型 SQL注入
发布时间 2019-10-25 更新时间 2019-10-31
CVE编号 CVE-2015-0270 CNNVD-ID CNNVD-201910-1493
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201910-1493
|漏洞详情
Zend Framework(ZF)是美国Zend公司的一套开源的PHP开发框架,它主要用于开发Web程序和服务。PostgreSQL ZendDb adapter是其中的一个PostgreSQL数据库适配器。 Zend ZF 2.2.10之前版本和2.3.5之前的2.3.x版本中的PostgreSQL ZendDb adapter存在SQL注入漏洞。该漏洞源于基于数据库的应用缺少对外部输入SQL语句的验证。攻击者可利用该漏洞执行非法SQL命令。
|参考资料

来源:framework.zend.com

链接:https://framework.zend.com/security/advisory/ZF2015-02


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2015-0270