Mercurial 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1803816 漏洞类型 信任管理问题
发布时间 2019-10-29 更新时间 2019-11-01
CVE编号 CVE-2010-4237 CNNVD-ID CNNVD-201910-1675
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201910-1675
|漏洞详情
Mercurial是Matt Mackall软件开发者的一套使用Python语言编写的跨平台的分布式版本控制软件。该软件支持同时处理纯文本和二进制文件等。 Mercurial 1.6.4之前版本中存在安全漏洞,该漏洞源于程序没有验证SSL凭证的Common Name字段。远程攻击者可利用该漏洞实施中间人攻击。
|参考资料

来源:security-tracker.debian.org

链接:https://security-tracker.debian.org/tracker/CVE-2010-4237


来源:bz.mercurial-scm.org

链接:https://bz.mercurial-scm.org/show_bug.cgi?id=2407


来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4237


来源:bugs.debian.org

链接:https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598841


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2010-4237