go-camo 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1822332 漏洞类型 跨站脚本
发布时间 2019-11-13 更新时间 2019-12-10
CVE编号 CVE-2019-18923 CNNVD-ID CNNVD-201911-774
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201911-774
|漏洞详情
go-camo是一款图像代理服务器。 go-camo 2.1.1之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。
|参考资料

来源:github.com

链接:https://github.com/cactus/go-camo/security/advisories/GHSA-jg2r-qf99-4wvr


来源:MISC

链接:https://github.com/cactus/go-camo/blob/505862f7bf14c8b6ff945734d5f3fdcd929e45dd/pkg/camo/proxy.go#L453-L460


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-18923