Pixie SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1829461 漏洞类型 SQL注入
发布时间 2019-11-19 更新时间 2019-11-21
CVE编号 CVE-2019-10766 CNNVD-ID CNNVD-201911-1162
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201911-1162
|漏洞详情
Pixie是一款基于PHP的数据库查询构建器。 Pixie 1.0.3之前的1.0.x版本和2.0.2之前的2.0.x版本中的‘limit()’函数存在SQL注入漏洞。该漏洞源于基于数据库的应用缺少对外部输入SQL语句的验证。攻击者可利用该漏洞执行非法SQL命令。
|参考资料

来源:snyk.io

链接:https://snyk.io/vuln/SNYK-PHP-USMANHALALITPIXIE-534879


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10766