Ruby OpenSSL extension 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1838125 漏洞类型 加密问题
发布时间 2019-11-26 更新时间 2020-07-23
CVE编号 CVE-2011-4121 CNNVD-ID CNNVD-201911-1402
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201911-1402
|漏洞详情
Ruby是松本行弘软件开发者的一种跨平台、面向对象的动态类型编程语言。OpenSSL extension是使用在其中的一个OpenSSL安全扩展程序。 Ruby 2011-09-01版本至2011-11-03版本中的OpenSSL extension存在加密问题漏洞。攻击者可借助特制请求利用该漏洞绕过安全限制。
|参考资料

来源:MISC

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-4121


来源:MISC

链接:http://www.openwall.com/lists/oss-security/2013/07/01/1


来源:access.redhat.com

链接:https://access.redhat.com/security/cve/cve-2011-4121


来源:MISC

链接:https://security-tracker.debian.org/tracker/CVE-2011-4121


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2011-4121