Pebble Templates 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1866771 漏洞类型 输入验证错误
发布时间 2019-12-18 更新时间 2020-01-17
CVE编号 CVE-2019-19899 CNNVD-ID CNNVD-201912-900
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201912-900
|漏洞详情
Pebble Templates是一款Java模板引擎。 Pebble Templates 3.1.2版本中存在安全漏洞。攻击者可借助公共静态java.lang.Class java.lang.Class.forName(java.lang.Module,java.lang.String)签名利用该漏洞绕过保护机制(阻止对java.lang.Class实例的访问)。
|参考资料

来源:github.com

链接:https://github.com/PebbleTemplates/pebble/issues/493


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-19899