CloudBees Jenkins 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1928864 漏洞类型 其他
发布时间 2020-01-29 更新时间 2020-03-04
CVE编号 CVE-2020-2107 CNNVD-ID CNNVD-202001-1305
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202001-1305
|漏洞详情
CloudBees Jenkins(Hudson Labs)是美国CloudBees公司的一套基于Java开发的持续集成工具。该产品主要用于监控持续的软件版本发布/测试项目和一些定时执行的任务。Fortify on Demand Plugin是使用在其中的一个支持从Jenkins上传代码以进行静态应用程序安全性测试的插件。 CloudBees Jenkins Fortify Plugin 19.1.29及之前版本中存在安全漏洞,该漏洞源于将未加密的代理服务器密码存储在Jenkins主服务器上的job config.xml文件中。攻击者可借助扩展读取权限或访问主文件系统利用该漏洞查看密码。
|参考资料

来源:jenkins.io

链接:https://jenkins.io/security/advisory/2020-01-29/#SECURITY-1565


来源:www.openwall.com

链接:http://www.openwall.com/lists/oss-security/2020/01/29/1


来源:ttps://jenkins.io/security/advisory/2020-01-29/

链接:无


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-2107


来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Jenkins-Plugins-three-vulnerabilities-31464


来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.0349/