Ratpack 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1928959 漏洞类型 跨站脚本
发布时间 2020-01-27 更新时间 2020-02-17
CVE编号 CVE-2019-10770 CNNVD-ID CNNVD-202001-1205
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202001-1205
|漏洞详情
Ratpack是一款用于构建可扩展HTTP应用程序的Java库。 io.ratpack:ratpack-core 0.9.10版本及之后版本(1.7.6版本已修复)中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。
|参考资料

来源:snyk.io

链接:https://snyk.io/vuln/SNYK-JAVA-IORATPACK-534882


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-10770