SimpleSAMLphp 日志信息泄露漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1929060 漏洞类型 日志信息泄露
发布时间 2020-01-24 更新时间 2020-03-24
CVE编号 CVE-2020-5225 CNNVD-ID CNNVD-202001-1106
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202001-1106
|漏洞详情
SimpleSAMLphp是一款实现了SAML 2.0服务提供者和标识提供者功能的PHP身份验证应用程序。 SimpleSAMLphp 1.18.4之前版本中存在日志信息泄露漏洞,该漏洞源于www/errorreport.php脚本未对reportID参数进行正确的清理。攻击者可利用该漏洞在SimpleSAMLphp文件中另起行并注入任意内容。
|参考资料

来源:github.com

链接:https://github.com/simplesamlphp/simplesamlphp/security/advisories/GHSA-6gc6-m364-85ww


来源:simplesamlphp.org

链接:https://simplesamlphp.org/security/202001-02


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-5225